Руководство пользователя. АРМ «Формирование отчётов»

Документ содержит инструкции пользователя для работы с приложением АРМ «Формирование отчётов».

Содержание

1. Вход в АРМ

1.1 Ошибки при входе в АРМ

2. Шаблоны отчётов

2.1 Создание шаблона отчёта

2.2 Редактирование шаблона отчёта

2.3 Выполнение отчёта по шаблону

2.4 Просмотр информации об отчёте

2.5 Просмотр отчёта

3. Задания

3.1 Создание задания

3.2 Редактирование задания

3.3 Выполнение задания

4. Журнал операций

5. Настройка локального прокси-сервера

6. Смена пароля

7. Выход из АРМа

Назначение АРМа

АРМ «Формирование отчётов» предназначен для:

oсоздания шаблонов отчётов;

oполучения отчётов с возможностью вывода отчёта в файл;

oвыполнения отчётов в реальном времени;

oсоздания заданий для запуска отчётов в автоматическом режиме с определенной периодичностью по расписанию.

Системные и программные требования

Операционная система

-Windows 7;

-Windows 8;

-Windows 8.1;

-Windows 10.

Терминология

АРМ «Формирование отчётов» (АРМ) – автоматизированное рабочее место, реализованное как приложение для управления отчётами.

Администратор – пользователь системы "Город" с необходимым набором прав и ролей для выполнения задач в АРМе «Формирование отчётов».

Версия документа: 21.11.0 © Все права защищены, ЗАО ЦФТ (Центр Финансовых Технологий), 2021


1. Вход в АРМ

1.Для запуска АРМа дважды щёлкните по ярлыку на рабочем столе Иконка АРМа.

2.Откроется окно входа в АРМ:

Вход в АРМ «Формирование отчётов»

Вход в АРМ «Формирование отчётов»

3.Введите ваш логин и пароль, нажмите "Вход".

АРМ «Формирование отчётов» можно настроить для работы с использованием локального прокси-сервера. Подробнее см. раздел "5. Настройка локального прокси-сервера" текущей документации.

a.При первом входе в АРМ потребуется сменить пароль, назначенный по умолчанию (1QAZ2WSX).

b.Откроется окно смены пароля:

Форма "Смена пароля"

Форма "Смена пароля"

c.Введите пароль по умолчанию, новый пароль и подтверждение нового пароля.

Про создании нового пароля необходимо учитывать требования к паролю, перечисленные на форме смены пароля. В дальнейшем при необходимости пароль также можно поменять в меню пользователя АРМа. Подробнее см. "5. Смена пароля" текущей документации.

d.Нажмите "Изменить".

4.Если логин и пароль для входа введены корректно, откроется рабочая область "Шаблоны отчётов".

a.Если возникли ошибки при входе в АРМ, ознакомьтесь с рекомендациями в разделе "1.1 Ошибки при входе в АРМ".

Рабочая область "Шаблоны отчётов"

Рабочая область "Шаблоны отчётов"


1.1 Ошибки при входе в АРМ

В случае возникновения ошибки при входе в АРМ появится информационное сообщение с текстом ошибки.

Примеры ошибок входа

1.Ошибка ввода логина/ пароля пользователя:

Ошибка ввода логина/ пароля пользователя

Нажмите "Продолжить" и введите логин и пароль пользователя заново.

2.Недостаточно прав для работы в АРМе:

Ошибка: недостаточно прав

Ошибка: недостаточно прав

Обратитесь в службу сопровождения Системы "Город" для предоставления необходимых прав вашему пользователю.


2. Шаблоны отчётов

Рабочая область "Шаблоны отчётов" предназначена для управления (поиск, создание, редактирование, выполнение, удаления) шаблонами отчётов.

Пункт меню "Шаблоны отчётов"

Пункт меню "Шаблоны отчётов"

При переходе в рабочую область выполняется автоматический поиск всех шаблонов и отчётов текущего пользователя.

Рабочая область "Шаблоны отчётов"

Рабочая область "Шаблоны отчётов"

Поиск шаблонов

Для более точного поиска установите параметры поиска и нажмите "Поиск" или клавишу Enter.

Параметры поиска представлены в таблице:

Параметр | Описание
Шаблон | Шаблон отчёта. Для поиска достаточно ввести несколько первых символов названия шаблона.
Отчёт | Выбор отчёта из выпадающего списка. В списке отображаются все доступные пользователю отчёты.

Результат поиска отобразится в таблице:

Пример результатов поиска шаблонов отчётов

Пример результатов поиска шаблонов отчётов

В таблице отображается следующая информация о шаблонах отчётов:

oТип – тип шаблона. Доступны два типа шаблона:

§ Шаблон по умолчанию Автоматический – шаблон, который можно только запустить на выполнение, также недоступен массовый запуск.

§ Шаблон пользовательский Пользовательский – шаблон, созданный текущим пользователем. Для него доступны все операции. Подробнее об операциях с шаблонами отчётов см. ниже.

Для получения подсказки с описанием типа шаблона наведите курсор мыши на нужный тип.

oШаблон – название шаблона отчёта. Для шаблонов, доступных пользователю по умолчанию (автоматических), название не указывается.

oОтчёт – название отчёта.

oСтатус последнего выполнения – состояние последнего выполнения отчёта. Поле может быть пустым, если отчёт еще не выполнялся.

§Создан – создан шаблон отчёта;

§В очереди – отчёт находится в очереди на выполнение (например в случае массового запуска шаблонов отчёта);

§Выполняется – отчёт в процессе выполнения;

§Завершён – отчёт сформирован, но не загружен на компьютер пользователя;

§Получен – отчёт сформирован и загружен на компьютер пользователя;

§Ошибка – при выполнении отчёта возникла ошибка.

oДата последнего выполнения – дата и время последнего выполнения отчёта. Поле может быть пустым, если отчёт еще не выполнялся.

Внизу таблицы слева отображается общее количество найденных записей.

Операции с шаблонами отчётов

Для просмотра доступных операций с шаблонами отчётов выделите нужные записи в таблице. Список операций отобразится на панели внизу таблицы:

Операции с шаблонами отчётов

Операции с шаблонами отчётов

Операции с шаблонами отчётов:

·Создание – по нажатию кнопки [image] "Добавить" открывается форма создания нового шаблона отчёта. Подробнее см. раздел "2.1 Создание шаблона отчёта" текущей документации.

·Редактирование – по нажатию кнопки [image] "Изменить" открывается форма редактирования шаблона отчёта. Подробнее см. раздел "2.2 Редактирование шаблона отчёта" текущей документации.

·Удаление – по нажатию кнопки Кнопка "Удалить" "Удалить" шаблон отчёта удаляется.

·Выполнение – по нажатию кнопки "Выполнить" запускается выполнение отчёта. Подробнее см. раздел "2.3 Выполнение отчёта по шаблону" текущей документации.

·Результат – по нажатию кнопки "Результат" открывается раздел "Журнал" АРМа с описанием подробностей выполнения выбранного отчёта. Подробнее см. раздел "2.4 Просмотр отчёта" текущей документации.

Для любого пользовательского отчёта операция "Выполнить" является массовой. Автоматические отчёты можно выполнять только по одному.


2.1 Создание шаблона отчёта

Для создания нового шаблона отчёта:

1.Нажмите кнопку [image] "Добавить".

2.Откроется форма создания шаблона отчёта:

Создание шаблона отчёта

Создание шаблона отчёта

3.Введите наименование шаблона.

4.Далее из выпадающего списка выберите доступный отчёт, который впоследствии будет выполняться по этому шаблону.

После выбора отчёта можно посмотреть подробную информацию о нем по нажатию кнопки Информация об отчёте . Подробнее см. раздел "2.4 Просмотр информации об отчёте" текущей документации.

5.В зависимости от выбранного отчёта на форму автоматически добавятся новые параметры для шаблона:

Пример добавления параметров на форму создания шаблонов

Пример добавления параметров на форму создания шаблонов

6.Все поля на форме обязательны для заполнения. Примечание: при смене отчёта в поле "Отчёт" также изменятся и параметры на форме.

Пример заполнения формы создания шаблона

Пример заполнения формы создания шаблона

7.После заполнения всех полей нажмите "Сохранить".

Если шаблон с указанными наименованием уже существует, отобразится сообщение об ошибке. Для продолжения создания шаблона введите другое наименование.

8.Отобразится сообщение с результатом операции:

Сообщение о создании шаблона

Сообщение о создании шаблона

9.Нажмите "Продолжить".

10.Запись о новом шаблоне появится в таблице шаблонов отчёта, поле "Статус последнего выполнения" будет пустым (т.к. отчёт по только что созданному шаблону еще не выполнялся).


2.2 Редактирование шаблона отчёта

Для редактирования шаблона отчёта:

1.Нажмите кнопку [image] "Изменить".

2.Откроется форма редактирования шаблона отчёта:

Изменение шаблона отчёта

Изменение шаблона отчёта

Для просмотра информации о выбранном отчёте нажмите Информация об отчёте . Подробнее см. раздел "2.4 Просмотр информации об отчёте" текущей документации.

3.Внесите необходимые изменения.

4.Нажмите "Сохранить".

5.Отобразится сообщение с результатом операции:

Сообщение об изменении шаблона

Сообщение об изменении шаблона

6.Нажмите "Продолжить".


2.3 Выполнение отчёта по шаблону

Для выполнения отчёта по шаблону:

1.Выберите необходимый шаблон в результатах поиска шаблонов отчётов.

2.Нажмите операцию "Выполнить".

Переход к выполнению отчёта

Переход к выполнению отчёта

a.Если выбран автоматический шаблон (без названия), то откроется расширенная форма с параметрами отчёта:

Форма параметров отчёта

Форма параметров отчёта

Для просмотра информации о выбранном отчёте нажмите Информация об отчёте . Подробнее см. раздел "2.4 Просмотр информации об отчёте" текущей документации.

i.Заполните все поля. Поле "Отчёт" недоступно для редактирования, т.е. выбрать другой отчёт нельзя.

ii.Если требуется сохранить этот отчёт в качестве шаблона, установите признак в поле "Сохранить как шаблон" и введите имя шаблона.

iii.Если сохранять отчёт не нужно, после заполнения всех полей (кроме признака "Сохранить как шаблон") нажмите "Продолжить".

3.Откроется форма выбора периода отчёта:

Выбор периода выполнения отчёта

Выбор периода выполнения отчёта

4.По умолчанию отчёт будет выполняться за последние две недели. Измените период отчёта при необходимости при помощи кнопки вызова календаря Кнопка "Календарь".

5.Нажмите "Выполнить".

6.АРМ сразу начнёт выполнять отчёт.

7.В процессе выполнения на значке с журналом операций в меню АРМа:

a.Будет отображаться количество отчётов, которые сейчас выполняются. Например: Выполнение нескольких отчётов

b.Если произошла ошибка, отобразится восклицательный знак: Ошибка выполнения отчёта в журнале

8.Нажмите на значок журнала для просмотра деталей операции. В частности, чтобы открыть файл выполненного отчёта.


2.4 Просмотр информации об отчёте

Для просмотра подробной информации о выбранном отчёте (описание, назначение, требования к заполнению полей и пр.):

1.Выберите шаблон для создания отчёта.

2.На панели операций нажмите "Выполнить".

3.В открывшейся форме с параметрами отчёта нажмите кнопку Информация об отчёте ("Информация об отчёте") или воспользуйтесь комбинацией клавиш Ctrl+F11.

Пример формы с параметрами отчёта

Пример формы с параметрами отчёта

4.Откроется окно с информацией о выбранном отчёте в формате pdf:

Пример отображения информации об отчёте

Пример отображения информации об отчёте


2.5 Просмотр отчёта

Для выполнения выполненного отчёта:

1.Выберите необходимый шаблон(-ы) в результатах поиска шаблонов отчётов.

2.Нажмите операцию "Результат". Она доступна, если отчёт по выбранному шаблону хотя бы раз выполнялся.

Переход к просмотру отчёта

Переход к просмотру отчёта

3.Откроется журнал операций:

Просмотр отчёта в журнале

Просмотр отчёта в журнале

4.Для просмотра отчёта в блоке "Показать в папке" нажмите кнопку "Показать". (Подробное описание полей в журнале операций см. в разделе "4. Журнал операций" текущей документации).

5.Откроется каталог с файлом выбранного отчёта в формате csv или txt. Пример каталога сохранения отчёта: C:\Users\Username\Documents\Формирование отчётов\Май\26\COMM4AGT_PAYS - Комиссии участников по платежам агента\Комиссия УФПС без группировки.

6.Откройте отчёт.


3. Задания

Рабочая область "Задания" предназначена для просмотра, создания и редактирования заданий на выполнение отчётов автоматически по расписанию.

Пункт меню "Задания"

Пункт меню "Задания"

При переходе в рабочую область выполняется автоматический поиск всех заданий, созданных текущим пользователем.

Рабочая область "Задания"

Рабочая область "Задания"

Поиск заданий

Для более точного поиска установите параметры поиска и нажмите "Поиск" или клавишу Enter.

Параметры поиска представлены в таблице:

Параметр | Описание
Наименование | Наименование задания. Для поиска достаточно ввести несколько символов наименования задания.
Шаблон | Выбор из выпадающего списка шаблона отчёта, который будет выполняться согласно заданию. В списке отображаются все доступные пользователю шаблоны.

Результат поиска отобразится в таблице:

Пример результатов поиска заданий

Пример результатов поиска заданий

В таблице отображается следующая информация о заданиях:

oНаименование – наименование задания.

oДата следующего выполнения – дата и время следующего выполнения задания.

oШаблоны – список шаблонов, по которым будут созданы отчёты согласно заданию.

Внизу таблицы слева отображается общее количество найденных записей.

Операции с заданиями

Для просмотра доступных операций с заданиями выделите нужные записи в таблице. Список операций отобразится на панели внизу таблицы:

Операции с заданиями

Операции с заданиями

Операции с заданиями:

·Создание – по нажатию кнопки [image] "Добавить" открывается форма создания нового задания. Подробнее см. раздел "3.1 Создание задания" текущей документации.

·Редактирование – по нажатию кнопки [image] "Изменить" открывается форма редактирования задания. Подробнее см. раздел "3.2 Редактирование задания" текущей документации.

·Удаление – по нажатию кнопки Кнопка "Удалить" "Удалить" задание удаляется.

·Выполнение – по нажатию кнопки "Выполнить" запускается выполнение отчёта по выбранному заданию, независимо от его расписания. Подробнее см. раздел "3.3 Выполнение задания" текущей документации.


3.1 Создание задания

Для создания нового задания:

1.Нажмите кнопку [image] "Добавить".

2.Откроется форма создания задания:

Форма создания задания

Форма создания задания

3.Заполните форму:

a.Введите наименование для задания.

b.В блоке "Выбор шаблонов" при помощи кнопок Добавить шаблон / [image] выберите те шаблоны, по которым будут выполняться отчёты создаваемого задания. По нажатию кнопки Добавить шаблон шаблон добавляется в список для выполнения. По нажатию кнопки [image] шаблон удаляется из списка. Шаблон также можно добавить или удалить из списка по двойному клику на его названии.

Выбор нескольких шаблонов для задания удобно использовать, когда необходимо сгруппировать несколько отчётов и выполнять их периодически вместе.

c.В блоке "Периодичность" установите период выполнения отчёта, нажав на нужное значение:

·Никогда – при выборе этого периода отчёт будет выполняться только вручную, без автоматического запуска по расписанию.

При выборе любого из остальных периодов на форме будут отображаться три ближайшие даты выполнения отчёта. По умолчанию запуск отчёта всегда в 07:00, время недоступно для изменения.

·День – при выборе этого периода отчёт будет выполняться ежедневно.

·Банковский день – при выборе этого периода отчёт будет выполняться каждый будний день за предыдущий день. В частности, в понедельник отчёт выполняется за три дня: пятницу, субботу и воскресенье.

Период выполнения задания - банковский день

·Неделя – при выборе этого периода на форму добавится поле, где необходимо указать день недели, в который будет выполняться отчёт.

Отчёт каждую неделю

·Месяц – при выборе этого периода на форму добавится поле, где необходимо указать число месяца, в который будет выполняться отчёт.

Отчёт каждый месц

·Квартал – при выборе этого периода отчёт будет выполняться в первый день каждого квартала.

Пример заполнения формы

Пример заполнения формы

4.После заполнения всех полей нажмите "Сохранить".

5.Отобразится сообщение с результатом операции:

Сообщение о создании задания

Сообщение о создании задания

6.Нажмите "Продолжить".

7.Запись о новом задании появится в таблице заданий. В поле "Дата следующего выполнения" будет указана первая дата выполнения отчёта по заданию.


3.2 Редактирование задания

Для редактирования задания:

1.Нажмите кнопку [image] "Изменить".

2.Откроется форма изменения задания:

Изменение задания

3.Внесите необходимые изменения. Все поля доступны для редактирования.

4.Нажмите "Сохранить".

5.Отобразится сообщение с результатом операции:

Сообщение об изменении задания

Сообщение об изменении задания

6.Нажмите "Продолжить".


3.3 Выполнение задания

Операция "Выполнить" предназначена для выполнения задания в текущий момент времени, независимо от установленного в нём расписания.

Для выполнения отчёта по заданию:

1.Выберите необходимое задание в таблице.

2.Нажмите операцию "Выполнить".

Переход к выполнению отчёта

Переход к выполнению отчёта

3.Откроется форма выбора периода задания:

Выбор периода выполнения задания

Выбор периода выполнения задания

4.По умолчанию задание будет выполняться за последние две недели. Измените период и время задания при необходимости при помощи кнопки вызова календаря Кнопка "Календарь".

5.Нажмите "Выполнить".

6.АРМ сразу начнёт выполнять задание.

7.В процессе выполнения задания на значке с журналом операций в меню АРМа:

a.Будет отображаться количество отчётов из задания, которые сейчас выполняются. Например: Выполнение нескольких отчётов

b.При успешном выполнении отчёта(-ов) отобразится соответствующий значок: Выполнение отчёта завершено успешно

c.Если произошла ошибка, отобразится восклицательный знак: Ошибка выполнения отчёта в журнале

8.Нажмите на значок журнала для просмотра деталей операции. В частности, чтобы открыть файл(-ы) выполненного отчёта.


4. Журнал операций

Рабочая область "Журнал" предназначена для:

oпросмотра истории выполнения отчётов;

oперехода к просмотру отчётов.

Пункт меню "Журнал"

Пункт меню "Журнал"

При выборе пункта меню "Журнал" открывается журнал операций c отчётами.

Просмотр отчёта в журнале

Просмотр отчёта в журнале

Журнал содержит следующую информацию по каждому выполненному шаблону отчёта или заданию:

oЗадание – наименование шаблона отчёта или задания.

oСоздан – дата и время создания шаблона отчёта или задания.

oСтатус – состояние последнего выполнения отчёта.

oОтчёт – наименование отчёта.

oДата – дата и время последнего изменения статуса отчёта.

oОшибка – информация об ошибке выполнения отчёта. По клику в тексте ошибки он будет скопирован в буфер обмена.

oПоказать в папке – кнопка перехода к папке с полученным отчётом. Если отчёт выполнен с ошибкой или находится в процессе выполнения, кнопка заблокирована.

oФайл – наименование файла отчёта.

Если требуется обновить данные в журнале, нажмите кнопку Кнопка "Обновить" в правом верхнем углу АРМа.


5. Настройка локального прокси-сервера

Для настройки работы с использованием локального прокси-сервера:

1.В окне входа в АРМ нажмите кнопку Кнопка "Настройки" .

2.Откроется форма с настройками прокси:

Форма настроек прокси-сервера

Форма настроек прокси-сервера

В АРМе предусмотрены три режима работы. Им соответствуют переключатели на форме "Параметры соединения". Для настройки прокси:

3.Выберите режим работы:

a.Без прокси – если для работы в АРМе не требуется использовать локальные настройки прокси. В этом случае все поля на форме недоступны для редактирования.

b.Использовать системные настройки прокси (значение по умолчанию) – если для работы в АРМе необходимо использовать системные настройки прокси, т.е. дополнительные настройки для работы в АРМе не требуются. В этом случае все поля на форме недоступны для редактирования.

c.Ручная настройка прокси – если для работы в АРМе необходимо использовать прокси, отличный от настроенного в системе или требующий аутентификации. Далее:

i.Укажите адрес и порт прокси-сервера.

ii.Поля "Логин" и "Пароль" доступны для редактирования, но необязательны для заполнения.

2.Нажмите "Проверить соединение" для проверки соединения с установленными настройками:

a.Если настройки корректны, отобразится сообщение:

Сообщение о корректных настройках прокси

Сообщение о корректных настройках прокси

b.Если возникла ошибка соединения, исправьте настройки и снова нажмите "Проверить соединение".

3.После успешной проверки соединения становится активной кнопка "Сохранить". Нажмите ее для сохранения изменений в настройках прокси.


6. Смена пароля

Для смены пароля пользователя:

1.В правом верхнем углу АРМа нажмите на значок с логином текущего пользователя.

2.Нажмите "Сменить пароль".

Операция "Сменить пароль"

Операция "Сменить пароль"

3.Откроется форма смены пароля.

Форма "Смена пароля"

Форма "Смена пароля"

4.Введите ваш текущий пароль (поле "Старый пароль"), новый пароль и подтверждение нового пароля.

Про создании нового пароля необходимо учитывать требования к паролю, перечисленные на форме смены пароля.


7. Выход из АРМа

5. Выход из АРМа

Для выхода из АРМа:

1.В правом верхнем углу АРМа нажмите на значок с логином текущего пользователя.

2.Выберите операцию "Выйти".

Выход из АРМа

Выход из АРМа


5. Смена пароля

Для смены пароля пользователя:

1.В правом верхнем углу АРМа нажмите на значок с логином текущего пользователя.

2.Нажмите "Сменить пароль".

Операция "Сменить пароль"

Операция "Сменить пароль"

3.Откроется форма смены пароля.

Форма "Смена пароля"

Форма "Смена пароля"

4.Введите ваш текущий пароль (поле "Старый пароль"), новый пароль и подтверждение нового пароля.

Про создании нового пароля необходимо учитывать требования к паролю, перечисленные на форме смены пароля.


6. Выход из АРМа

5. Выход из АРМа

Для выхода из АРМа:

1.В правом верхнем углу АРМа нажмите на значок с логином текущего пользователя.

2.Нажмите "Выйти".

Выход из АРМа

Выход из АРМа


4. Журнал операций

Рабочая область "Журнал" предназначена для:

·просмотра истории выполнения отчётов;

·перехода к просмотру отчётов.

Пункт меню "Журнал"

Пункт меню "Журнал"

При выборе пункта меню "Журнал" открывается журнал операций c отчётами.

Просмотр отчёта в журнале

Просмотр отчёта в журнале

Журнал содержит следующую информацию по каждому выполненному шаблону отчёта или заданию:

oЗадание – наименование шаблона отчёта или задания.

oСоздан – дата и время создания шаблона отчёта или задания.

oСтатус – состояние последнего выполнения отчёта.

oОтчёт – наименование отчёта.

oДата – дата и время последнего изменения статуса отчёта.

oОшибка – информация об ошибке выполнения отчёта. По клику в тексте ошибки он будет скопирован в буфер обмена.

oПоказать в папке – кнопка перехода к папке с полученным отчётом. Если отчёт выполнен с ошибкой или находится в процессе выполнения, кнопка заблокирована.

oФайл – наименование архива с файлом отчёта.

Если требуется обновить данные в журнале, нажмите кнопку Кнопка "Обновить" в правом верхнем углу АРМа.


5. Выход из АРМа

Для выхода из АРМа:

1.В правом верхнем углу АРМа нажмите на значок с логином текущего пользователя.

2.Нажмите "Выйти".

Выход из АРМа

Выход из АРМа